Setting up Let’s Encrypt with NGINX on Ubuntu

Guide on how to secure a NGINX vhost with a Let’s Encrypt certificate.
Read more →

Recompile NGINX with OpenSSL 1.0.2+ for HTTP/2 via ALPN - Ubuntu 14.04

Since Chrome is soon dropping HTTP/2 via NPN we need to support HTTP/2 via ALPN, however… on Ubuntu 14.04 NGINX has been compiled with OpenSSL 1.0.1 which does not support ALPN :( So let’s fix that! First we need to upgrade OpenSSL, since that is not that easy to do ourselfs I use the package repository provided by Ondřej Surý for originally PHP but also includes a up-to-date OpenSSL package.
Read more →